Install Evolution 3.10.x Mint 16

Even with the ubuntu updates repo from the gnome 3 team, there are still some dependency mismatches.  I know this is risky, so repeat at your own risk, but so far its worked for me.
sudo -E add-apt-repository ppa:gnome3-team/gnome3
sudo apt-get update
Force the update of the libwebkitgtk packages that Evolution 3.10 requires.  You must install all 3 dependencies at once!

sudo apt-get install libwebkitgtk-3.0-common=2.3.2-1ubuntu6~saucy1  libjavascriptcoregtk-3.0-0=2.3.2-1ubuntu6~saucy1 libwebkitgtk-3.0-0=2.3.2-1ubuntu6~saucy1

sudo apt-get install evolution evolution-dbg evolution-ews

WARNING: You should disable the gnome3 ppa after this as doing a dist-upgrade with this repo breaks wifi!